Twój serwer korzysta z PHP w wersji 5.1.6, lecz WordPress 3.4.2 wymaga co najmniej wersji 5.2.4.